
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML+RDFa 1.0//EN" "http://www.w3.org/MarkUp/DTD/xhtml-rdfa-1.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en" dir="ltr" class="no-js">

    <head>
        <meta name="Opus-Version" content="4.6" />
        <meta http-equiv="Last-Modified" content="Fri, 12 Jan 2018 15:44:32 +0100" />
        <meta name="DC.Creator" content="Beyhl, Thomas" />
        <meta name="author" content="Beyhl, Thomas" />
        <meta name="citation_author" content="Beyhl, Thomas" />
        <meta name="DC.title" content="A framework for incremental view graph maintenance" />
        <meta name="title" content="A framework for incremental view graph maintenance" />
        <meta name="citation_title" content="A framework for incremental view graph maintenance" />
        <meta name="DC.title" content="Ein Framework für die inkrementelle Wartung von Sichten auf Graphen" />
        <meta name="title" content="Ein Framework für die inkrementelle Wartung von Sichten auf Graphen" />
        <meta name="citation_title" content="Ein Framework für die inkrementelle Wartung von Sichten auf Graphen" />
        <meta name="DC.Description" content="Nowadays, graph data models are employed, when relationships between entities have to be stored and are in the scope of queries. For each entity, this graph data model locally stores relationships to adjacent entities. Users employ graph queries to query and modify these entities and relationships. These graph queries employ graph patterns to lookup all subgraphs in the graph data that satisfy certain graph structures. These subgraphs are called graph pattern matches. However, this graph pattern matching is NP-complete for subgraph isomorphism. Thus, graph queries can suffer a long response time, when the number of entities and relationships in the graph data or the graph patterns increases.
One possibility to improve the graph query performance is to employ graph views that keep ready graph pattern matches for complex graph queries for later retrieval. However, these graph views must be maintained by means of an incremental graph pattern matching to keep them consistent with the graph data from which they are derived, when the graph data changes. This maintenance adds subgraphs that satisfy a graph pattern to the graph views and removes subgraphs that do not satisfy a graph pattern anymore from the graph views.
Current approaches for incremental graph pattern matching employ Rete networks. Rete networks are discrimination networks that enumerate and maintain all graph pattern matches of certain graph queries by employing a network of condition tests, which implement partial graph patterns that together constitute the overall graph query. Each condition test stores all subgraphs that satisfy the partial graph pattern. Thus, Rete networks suffer high memory consumptions, because they store a large number of partial graph pattern matches. But, especially these partial graph pattern matches enable Rete networks to update the stored graph pattern matches efficiently, because the network maintenance exploits the already stored partial graph pattern matches to find new graph pattern matches. However, other kinds of discrimination networks exist that can perform better in time and space than Rete networks. Currently, these other kinds of networks are not used for incremental graph pattern matching.
This thesis employs generalized discrimination networks for incremental graph pattern matching. These discrimination networks permit a generalized network structure of condition tests to enable users to steer the trade-off between memory consumption and execution time for the incremental graph pattern matching. For that purpose, this thesis contributes a modeling language for the effective definition of generalized discrimination networks. Furthermore, this thesis contributes an efficient and scalable incremental maintenance algorithm, which updates the (partial) graph pattern matches that are stored by each condition test. Moreover, this thesis provides a modeling evaluation, which shows that the proposed modeling language enables the effective modeling of generalized discrimination networks. Furthermore, this thesis provides a performance evaluation, which shows that a) the incremental maintenance algorithm scales, when the graph data becomes large, and b) the generalized discrimination network structures can outperform Rete network structures in time and space at the same time for incremental graph pattern matching." />
        <meta name="description" content="Nowadays, graph data models are employed, when relationships between entities have to be stored and are in the scope of queries. For each entity, this graph data model locally stores relationships to adjacent entities. Users employ graph queries to query and modify these entities and relationships. These graph queries employ graph patterns to lookup all subgraphs in the graph data that satisfy certain graph structures. These subgraphs are called graph pattern matches. However, this graph pattern matching is NP-complete for subgraph isomorphism. Thus, graph queries can suffer a long response time, when the number of entities and relationships in the graph data or the graph patterns increases.
One possibility to improve the graph query performance is to employ graph views that keep ready graph pattern matches for complex graph queries for later retrieval. However, these graph views must be maintained by means of an incremental graph pattern matching to keep them consistent with the graph data from which they are derived, when the graph data changes. This maintenance adds subgraphs that satisfy a graph pattern to the graph views and removes subgraphs that do not satisfy a graph pattern anymore from the graph views.
Current approaches for incremental graph pattern matching employ Rete networks. Rete networks are discrimination networks that enumerate and maintain all graph pattern matches of certain graph queries by employing a network of condition tests, which implement partial graph patterns that together constitute the overall graph query. Each condition test stores all subgraphs that satisfy the partial graph pattern. Thus, Rete networks suffer high memory consumptions, because they store a large number of partial graph pattern matches. But, especially these partial graph pattern matches enable Rete networks to update the stored graph pattern matches efficiently, because the network maintenance exploits the already stored partial graph pattern matches to find new graph pattern matches. However, other kinds of discrimination networks exist that can perform better in time and space than Rete networks. Currently, these other kinds of networks are not used for incremental graph pattern matching.
This thesis employs generalized discrimination networks for incremental graph pattern matching. These discrimination networks permit a generalized network structure of condition tests to enable users to steer the trade-off between memory consumption and execution time for the incremental graph pattern matching. For that purpose, this thesis contributes a modeling language for the effective definition of generalized discrimination networks. Furthermore, this thesis contributes an efficient and scalable incremental maintenance algorithm, which updates the (partial) graph pattern matches that are stored by each condition test. Moreover, this thesis provides a modeling evaluation, which shows that the proposed modeling language enables the effective modeling of generalized discrimination networks. Furthermore, this thesis provides a performance evaluation, which shows that a) the incremental maintenance algorithm scales, when the graph data becomes large, and b) the generalized discrimination network structures can outperform Rete network structures in time and space at the same time for incremental graph pattern matching." />
        <meta name="DC.Description" content="Heutzutage werden Graphdatenmodelle verwendet um Beziehungen zwischen Entitäten zu speichern und diese Beziehungen später abzufragen. Jede Entität im Graphdatenmodell speichert lokal die Beziehungen zu anderen verknüpften Entitäten. Benutzer stellen Suchanfragen um diese Entitäten und Beziehungen abzufragen und zu modifizieren. Dafür machen Suchanfragen Gebrauch von Graphmustern um alle Teilgraphen in den Graphdaten zu finden, die über bestimmte Graphstrukturen verfügen. Diese Teilgraphen werden Graphmusterübereinstimmung (Match) genannt. Allerdings ist diese Suche nach Matches NP-vollständig für Teilgraphisomorphie. Daher können Suchanfragen einer langen Antwortzeit unterliegen, wenn die Anzahl von Entitäten und Beziehungen in den Graphdaten oder -mustern ansteigt.
Eine Möglichkeit die Antwortzeiten von Suchanfragen zu verbessern ist Matches für komplexe Suchanfragen in sogenannten Sichten über die Graphdaten für spätere Suchanfragen bereitzuhalten. Allerdings müssen diese Sichten mittels einer inkrementellen Suche nach Matches gewartete werden um sie konsistent zu den sich ändernden Graphdaten zu halten. Diese Wartung ergänzt Teilgraphen, die Graphmuster erfüllen, in den Sichten und entfernt Teilgraphen, die Graphmuster nicht mehr erfüllen, aus den Sichten.
Aktuelle Ansätze für die inkrementelle Suche nach Matches verwenden Rete Netzwerke. Rete Netzwerke sind sogenannte Discrimination Networks, die alle Matches für bestimmte Suchanfragen aufzählen und warten, indem sie ein Netzwerk aus einzelnen Teilgraphmustern anwenden, die zusammen eine vollständige Suchanfrage ergeben. Das Netzwerk speichert für jedes Teilgraphmuster welche Teilgraphen das Teilgraphmuster erfüllen. Daher haben Rete Netzwerke einen hohen Speicherverbrauch, da sie alle Zwischenergebnisse speichern müssen. Jedoch sind es gerade diese gespeicherten Zwischenergebnisse, die es dem Rete Netzwerk ermöglichen die gespeicherten Zwischenergebnisse effizient zu warten, da diese Zwischenergebnisse für das Auffinden neuer Matches ausgenutzt werden. Allerdings existieren andere Arten von Discrimination Networks, die hinsichtlich Speicher- und Zeitverbrauch effizienter sind, aber derzeit nicht für die inkrementelle Suche nach Matches verwendet werden.
Diese Doktorarbeit wendet eine verallgemeinerte Art von Discrimination Networks an. Diese verallgemeinerte Art ermöglicht es die Balance zwischen Speicher- und Zeitverbrauch für die inkrementelle Suche nach Matches zu steuern. Dafür stellt diese Arbeit eine Modellierungssprache vor, die es ermöglicht verallgemeinerte Arten von Discrimination Networks effektiv zu spezifizieren. Darauf aufbauend stellt diese Arbeit einen inkrementellen Algorithmus vor, der die gespeicherten Matches effizient und skalierbar wartet. Abschließend stellt diese Arbeit eine Evaluierung vor, die aufzeigt dass die Modellierungssprache eine effektive Spezifikation von verallgemeinerten Discrimination Networks erlaubt. Außerdem zeigt die Evaluierung, dass a) der inkrementelle Wartungsalgorithmus für große Graphdaten skaliert und b) die Netzwerkstrukturen von verallgemeinerten Discrimination Networks im Vergleich zu den Netzwerkstrukturen von Rete Netzwerken im Speicher- und Zeitverbrauch für die inkrementelle Suche nach Matches effizienter sein können." />
        <meta name="description" content="Heutzutage werden Graphdatenmodelle verwendet um Beziehungen zwischen Entitäten zu speichern und diese Beziehungen später abzufragen. Jede Entität im Graphdatenmodell speichert lokal die Beziehungen zu anderen verknüpften Entitäten. Benutzer stellen Suchanfragen um diese Entitäten und Beziehungen abzufragen und zu modifizieren. Dafür machen Suchanfragen Gebrauch von Graphmustern um alle Teilgraphen in den Graphdaten zu finden, die über bestimmte Graphstrukturen verfügen. Diese Teilgraphen werden Graphmusterübereinstimmung (Match) genannt. Allerdings ist diese Suche nach Matches NP-vollständig für Teilgraphisomorphie. Daher können Suchanfragen einer langen Antwortzeit unterliegen, wenn die Anzahl von Entitäten und Beziehungen in den Graphdaten oder -mustern ansteigt.
Eine Möglichkeit die Antwortzeiten von Suchanfragen zu verbessern ist Matches für komplexe Suchanfragen in sogenannten Sichten über die Graphdaten für spätere Suchanfragen bereitzuhalten. Allerdings müssen diese Sichten mittels einer inkrementellen Suche nach Matches gewartete werden um sie konsistent zu den sich ändernden Graphdaten zu halten. Diese Wartung ergänzt Teilgraphen, die Graphmuster erfüllen, in den Sichten und entfernt Teilgraphen, die Graphmuster nicht mehr erfüllen, aus den Sichten.
Aktuelle Ansätze für die inkrementelle Suche nach Matches verwenden Rete Netzwerke. Rete Netzwerke sind sogenannte Discrimination Networks, die alle Matches für bestimmte Suchanfragen aufzählen und warten, indem sie ein Netzwerk aus einzelnen Teilgraphmustern anwenden, die zusammen eine vollständige Suchanfrage ergeben. Das Netzwerk speichert für jedes Teilgraphmuster welche Teilgraphen das Teilgraphmuster erfüllen. Daher haben Rete Netzwerke einen hohen Speicherverbrauch, da sie alle Zwischenergebnisse speichern müssen. Jedoch sind es gerade diese gespeicherten Zwischenergebnisse, die es dem Rete Netzwerk ermöglichen die gespeicherten Zwischenergebnisse effizient zu warten, da diese Zwischenergebnisse für das Auffinden neuer Matches ausgenutzt werden. Allerdings existieren andere Arten von Discrimination Networks, die hinsichtlich Speicher- und Zeitverbrauch effizienter sind, aber derzeit nicht für die inkrementelle Suche nach Matches verwendet werden.
Diese Doktorarbeit wendet eine verallgemeinerte Art von Discrimination Networks an. Diese verallgemeinerte Art ermöglicht es die Balance zwischen Speicher- und Zeitverbrauch für die inkrementelle Suche nach Matches zu steuern. Dafür stellt diese Arbeit eine Modellierungssprache vor, die es ermöglicht verallgemeinerte Arten von Discrimination Networks effektiv zu spezifizieren. Darauf aufbauend stellt diese Arbeit einen inkrementellen Algorithmus vor, der die gespeicherten Matches effizient und skalierbar wartet. Abschließend stellt diese Arbeit eine Evaluierung vor, die aufzeigt dass die Modellierungssprache eine effektive Spezifikation von verallgemeinerten Discrimination Networks erlaubt. Außerdem zeigt die Evaluierung, dass a) der inkrementelle Wartungsalgorithmus für große Graphdaten skaliert und b) die Netzwerkstrukturen von verallgemeinerten Discrimination Networks im Vergleich zu den Netzwerkstrukturen von Rete Netzwerken im Speicher- und Zeitverbrauch für die inkrementelle Suche nach Matches effizienter sein können." />
        <meta name="DC.subject" content="incremental graph pattern matching" />
        <meta name="DC.subject" content="discrimination networks" />
        <meta name="DC.subject" content="Rete networks" />
        <meta name="DC.subject" content="Gator networks" />
        <meta name="DC.subject" content="model-driven software engineering" />
        <meta name="DC.subject" content="inkrementelle Graphmustersuche" />
        <meta name="DC.subject" content="Discrimination Networks" />
        <meta name="DC.subject" content="Rete Netzwerk" />
        <meta name="DC.subject" content="Gator Netzwerk" />
        <meta name="DC.subject" content="modellgetriebene Softwareentwicklung" />
        <meta name="keywords" content="incremental graph pattern matching, discrimination networks, Rete networks, Gator networks, model-driven software engineering, inkrementelle Graphmustersuche, Discrimination Networks, Rete Netzwerk, Gator Netzwerk, modellgetriebene Softwareentwicklung" />
        <meta name="DC.Identifier" content="urn:nbn:de:kobv:517-opus4-405929" />
        <meta name="DC.Identifier" content="https://nbn-resolving.org/urn:nbn:de:kobv:517-opus4-405929" />
        <meta name="DC.Identifier" content="https://publishup.uni-potsdam.de/frontdoor/index/index/docId/40592" />
        <meta name="DC.Identifier" content="https://publishup.uni-potsdam.de/files/40592/beyhl_diss.pdf" />
        <meta name="citation_pdf_url" content="https://publishup.uni-potsdam.de/files/40592/beyhl_diss.pdf" />
        <meta name="DC.rights" content="https://creativecommons.org/licenses/by-nc-sa/4.0/deed.de" />
        <meta name="google-site-verification" content="D0OVUNNKFCRrcbNCkHCtCLyewQGUlQHOdNRJmw3mQcY" />
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <meta http-equiv="Content-Language" content="de-DE" />
        <title>publish.UP A framework for incremental view graph maintenance</title>
        <link href="/assets/jquery-ui/themes/base/jquery-ui.css" media="screen" rel="stylesheet" type="text/css" />
        <link href="/layouts/pmatrix/css/opus.css" media="screen,print" rel="stylesheet" type="text/css" />
        <link href="/layouts/pmatrix/css/admin.css" media="screen,print" rel="stylesheet" type="text/css" />
        <link href="/layouts/pmatrix/img/logo/favicon.ico" rel="shortcut icon" type="image/x-icon" />
        <link href="https://publishup.uni-potsdam.de/solrsearch/opensearch" rel="search" type="application/opensearchdescription+xml" title="OPUS 4 Search" />
        <link href="/layouts/pmatrix/css/custom.css" media="screen" rel="stylesheet" type="text/css" />
        <link href="/layouts/pmatrix/css/oas/jquery-ui.min.css" media="screen" rel="stylesheet" type="text/css" />
        <link href="/layouts/pmatrix/css/oas/morris.css" media="screen" rel="stylesheet" type="text/css" />
        <link href="/layouts/pmatrix/css/oas/oaswidget.css" media="screen" rel="stylesheet" type="text/css" />

        <script type="text/javascript">
        //<![CDATA[
            window.opusBaseUrl = 'https://publishup.uni-potsdam.de';
        //]]>
        </script>

        <script type="text/javascript" src="/assets/jquery/jquery.js"></script>
        <script type="text/javascript" src="/assets/jquery-ui/jquery-ui.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/searchutil.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/frontdoorutil.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/submit.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/oas/jquery-1.11.1.min.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/oas/raphael-min.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/oas/jquery-ui.min.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/oas/morris.min.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/oas/datepicker-de.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/oas/oaswidget.js"></script>
        <script type="text/javascript" src="/layouts/pmatrix/js/oas/oaswidget-de.js"></script>
	<!--[if IE 6]>
        <link rel="stylesheet" type="text/css" href="/layouts/pmatrix/css/opus-ie.css" />
        <![endif]-->

        <!--[if lt IE 9]>
        <link rel="stylesheet" type="text/css" href="/layouts/pmatrix/css/opus-ie-7.css" />
        <![endif]-->
    </head>

    <body>
        <div id="container">
            <div id="top-header">
                <div class="wrapper">
                                            <ul id="lang-switch" class="nav" title="Choose your language">
                                                            <li class="first"><a href="/home/index/language/language/de/rmodule/frontdoor/rcontroller/index/raction/index/docId/40592" title="Deutsch">Deutsch</a></li>
                                                    </ul>
                                     

                </div>



                        </div>

            <div id="header">
                <div class="wrapper">
                    <h1 id="logo">
                        <a href="http://www.uni-potsdam.de/"><img src="/layouts/pmatrix/img/logo/unilogo.png" alt="University Logo" title="University of Potsdam" width="83" height="91" /></a>
                    </h1>
                    <ul id="primary-nav" class="nav">
                                                                    <li id="primary-nav-home" class="first">
                            <a href="/home" title="Home">
                                                                    <span>Home</span>
                                                            </a>
                        </li>
                                                                    <li id="primary-nav-search" class="icon">
                            <a href="/solrsearch" title="Search">
                                                                    <span>Search</span>
                                                            </a>
                        </li>
                                                                    <li id="primary-nav-browsing" class="icon">
                            <a href="/solrsearch/browse" title="Browse">
                                                                    <span>Browse</span>
                                                            </a>
                        </li>
                                                                    <li id="primary-nav-publish" class="icon">
                            <a href="/publish" title="Submit">
                                                                    <span>Submit</span>
                                                            </a>
                        </li>
                                                                    <li id="primary-nav-help" class="last">
                            <a href="/home/index/help" title="Sitemap">
                                                                    <span>Sitemap</span>
                                                            </a>
                        </li>
                                        </ul>
                </div>
            </div>
			
			<div id="oas" class="white_content">
             <div class="oas_close"><a href = "javascript:void(0)" onclick = "document.getElementById('oas').style.display='none'; document.getElementById('fade').style.display='none'">Schlie&szlig;en</a></div></div>
			<div id="fade" class="black_overlay"></div>

            <div id="content" class="opus  frontdoor">
                
                                                    

                                    

                    <div class="wrapper">
                        
<div class="frontdoor">
    
    <div about="A framework for incremental view graph maintenance"><div id="titlemain-wrapper"><h2 class="titlemain">A framework for incremental view graph maintenance</h2><h3 class="titlemain">Ein Framework für die inkrementelle Wartung von Sichten auf Graphen</h3></div><div id="result-data"><div id="author"><p><a href="/solrsearch/index/search/searchtype/authorsearch/author/Thomas+Beyhl" title="Search for other publications by this author">Thomas Beyhl</a></p></div><div id="abstract"><ul><li class="abstract preserve-spaces"><span id="abstractShort_76257" class="abstractShort">Nowadays, graph data models are employed, when relationships between entities have to be stored and are in the scope of queries. For each entity, this graph data model locally stores relationships to adjacent entities. Users employ graph queries to query and modify these entities and relationships. These graph queries employ graph patterns to lookup all subgraphs in the graph data that satisfy certain graph structures. These subgraphs are called graph pattern matches. However, this graph pattern matching is NP-complete for subgraph isomorphism. Thus, graph queries can suffer a long response time, when the number of entities and relationships in the graph data or the graph patterns increases.&#13;
One possibility to improve the graph query performance is to employ graph views that keep ready graph pattern matches for complex graph queries for later retrieval. However, these graph views must be maintained by means of an incremental graph pattern matching to keep them consistent with the graph data from which they are derived, when the graph</span><span id="abstractFull_76257" class="abstractFull">Nowadays, graph data models are employed, when relationships between entities have to be stored and are in the scope of queries. For each entity, this graph data model locally stores relationships to adjacent entities. Users employ graph queries to query and modify these entities and relationships. These graph queries employ graph patterns to lookup all subgraphs in the graph data that satisfy certain graph structures. These subgraphs are called graph pattern matches. However, this graph pattern matching is NP-complete for subgraph isomorphism. Thus, graph queries can suffer a long response time, when the number of entities and relationships in the graph data or the graph patterns increases.&#13;
One possibility to improve the graph query performance is to employ graph views that keep ready graph pattern matches for complex graph queries for later retrieval. However, these graph views must be maintained by means of an incremental graph pattern matching to keep them consistent with the graph data from which they are derived, when the graph data changes. This maintenance adds subgraphs that satisfy a graph pattern to the graph views and removes subgraphs that do not satisfy a graph pattern anymore from the graph views.&#13;
Current approaches for incremental graph pattern matching employ Rete networks. Rete networks are discrimination networks that enumerate and maintain all graph pattern matches of certain graph queries by employing a network of condition tests, which implement partial graph patterns that together constitute the overall graph query. Each condition test stores all subgraphs that satisfy the partial graph pattern. Thus, Rete networks suffer high memory consumptions, because they store a large number of partial graph pattern matches. But, especially these partial graph pattern matches enable Rete networks to update the stored graph pattern matches efficiently, because the network maintenance exploits the already stored partial graph pattern matches to find new graph pattern matches. However, other kinds of discrimination networks exist that can perform better in time and space than Rete networks. Currently, these other kinds of networks are not used for incremental graph pattern matching.&#13;
This thesis employs generalized discrimination networks for incremental graph pattern matching. These discrimination networks permit a generalized network structure of condition tests to enable users to steer the trade-off between memory consumption and execution time for the incremental graph pattern matching. For that purpose, this thesis contributes a modeling language for the effective definition of generalized discrimination networks. Furthermore, this thesis contributes an efficient and scalable incremental maintenance algorithm, which updates the (partial) graph pattern matches that are stored by each condition test. Moreover, this thesis provides a modeling evaluation, which shows that the proposed modeling language enables the effective modeling of generalized discrimination networks. Furthermore, this thesis provides a performance evaluation, which shows that a) the incremental maintenance algorithm scales, when the graph data becomes large, and b) the generalized discrimination network structures can outperform Rete network structures in time and space at the same time for incremental graph pattern matching.</span><span id="abstractThreeDots_76257" class="abstractThreeDots">…</span><img src="/layouts/pmatrix/img/arrow_down.png" id="abstractButtonShow_76257" class="abstractButtonShow abstractButton" title="show more" alt="show more"/><img src="/layouts/pmatrix/img/arrow_up.png" id="abstractButtonHide_76257" class="abstractButtonHide abstractButton" title="show less" alt="show less"/></li><li class="abstract preserve-spaces"><span id="abstractShort_76258" class="abstractShort">Heutzutage werden Graphdatenmodelle verwendet um Beziehungen zwischen Entitäten zu speichern und diese Beziehungen später abzufragen. Jede Entität im Graphdatenmodell speichert lokal die Beziehungen zu anderen verknüpften Entitäten. Benutzer stellen Suchanfragen um diese Entitäten und Beziehungen abzufragen und zu modifizieren. Dafür machen Suchanfragen Gebrauch von Graphmustern um alle Teilgraphen in den Graphdaten zu finden, die über bestimmte Graphstrukturen verfügen. Diese Teilgraphen werden Graphmusterübereinstimmung (Match) genannt. Allerdings ist diese Suche nach Matches NP-vollständig für Teilgraphisomorphie. Daher können Suchanfragen einer langen Antwortzeit unterliegen, wenn die Anzahl von Entitäten und Beziehungen in den Graphdaten oder -mustern ansteigt.&#13;
Eine Möglichkeit die Antwortzeiten von Suchanfragen zu verbessern ist Matches für komplexe Suchanfragen in sogenannten Sichten über die Graphdaten für spätere Suchanfragen bereitzuhalten. Allerdings müssen diese Sichten mittels einer inkrementellen</span><span id="abstractFull_76258" class="abstractFull">Heutzutage werden Graphdatenmodelle verwendet um Beziehungen zwischen Entitäten zu speichern und diese Beziehungen später abzufragen. Jede Entität im Graphdatenmodell speichert lokal die Beziehungen zu anderen verknüpften Entitäten. Benutzer stellen Suchanfragen um diese Entitäten und Beziehungen abzufragen und zu modifizieren. Dafür machen Suchanfragen Gebrauch von Graphmustern um alle Teilgraphen in den Graphdaten zu finden, die über bestimmte Graphstrukturen verfügen. Diese Teilgraphen werden Graphmusterübereinstimmung (Match) genannt. Allerdings ist diese Suche nach Matches NP-vollständig für Teilgraphisomorphie. Daher können Suchanfragen einer langen Antwortzeit unterliegen, wenn die Anzahl von Entitäten und Beziehungen in den Graphdaten oder -mustern ansteigt.&#13;
Eine Möglichkeit die Antwortzeiten von Suchanfragen zu verbessern ist Matches für komplexe Suchanfragen in sogenannten Sichten über die Graphdaten für spätere Suchanfragen bereitzuhalten. Allerdings müssen diese Sichten mittels einer inkrementellen Suche nach Matches gewartete werden um sie konsistent zu den sich ändernden Graphdaten zu halten. Diese Wartung ergänzt Teilgraphen, die Graphmuster erfüllen, in den Sichten und entfernt Teilgraphen, die Graphmuster nicht mehr erfüllen, aus den Sichten.&#13;
Aktuelle Ansätze für die inkrementelle Suche nach Matches verwenden Rete Netzwerke. Rete Netzwerke sind sogenannte Discrimination Networks, die alle Matches für bestimmte Suchanfragen aufzählen und warten, indem sie ein Netzwerk aus einzelnen Teilgraphmustern anwenden, die zusammen eine vollständige Suchanfrage ergeben. Das Netzwerk speichert für jedes Teilgraphmuster welche Teilgraphen das Teilgraphmuster erfüllen. Daher haben Rete Netzwerke einen hohen Speicherverbrauch, da sie alle Zwischenergebnisse speichern müssen. Jedoch sind es gerade diese gespeicherten Zwischenergebnisse, die es dem Rete Netzwerk ermöglichen die gespeicherten Zwischenergebnisse effizient zu warten, da diese Zwischenergebnisse für das Auffinden neuer Matches ausgenutzt werden. Allerdings existieren andere Arten von Discrimination Networks, die hinsichtlich Speicher- und Zeitverbrauch effizienter sind, aber derzeit nicht für die inkrementelle Suche nach Matches verwendet werden.&#13;
Diese Doktorarbeit wendet eine verallgemeinerte Art von Discrimination Networks an. Diese verallgemeinerte Art ermöglicht es die Balance zwischen Speicher- und Zeitverbrauch für die inkrementelle Suche nach Matches zu steuern. Dafür stellt diese Arbeit eine Modellierungssprache vor, die es ermöglicht verallgemeinerte Arten von Discrimination Networks effektiv zu spezifizieren. Darauf aufbauend stellt diese Arbeit einen inkrementellen Algorithmus vor, der die gespeicherten Matches effizient und skalierbar wartet. Abschließend stellt diese Arbeit eine Evaluierung vor, die aufzeigt dass die Modellierungssprache eine effektive Spezifikation von verallgemeinerten Discrimination Networks erlaubt. Außerdem zeigt die Evaluierung, dass a) der inkrementelle Wartungsalgorithmus für große Graphdaten skaliert und b) die Netzwerkstrukturen von verallgemeinerten Discrimination Networks im Vergleich zu den Netzwerkstrukturen von Rete Netzwerken im Speicher- und Zeitverbrauch für die inkrementelle Suche nach Matches effizienter sein können.</span><span id="abstractThreeDots_76258" class="abstractThreeDots">…</span><img src="/layouts/pmatrix/img/arrow_down.png" id="abstractButtonShow_76258" class="abstractButtonShow abstractButton" title="show more" alt="show more"/><img src="/layouts/pmatrix/img/arrow_up.png" id="abstractButtonHide_76258" class="abstractButtonHide abstractButton" title="show less" alt="show less"/></li></ul></div></div><div id="services" class="services-menu"><div id="download-fulltext" class="services"><h3>Download full text files</h3><ul><li><div class="accessible-file" title="Download file beyhl_diss.pdf (application/pdf)"><a class="application_pdf" href="/files/40592/beyhl_diss.pdf">beyhl_diss.pdf</a><img width="16" height="11" src="/img/lang/eng.png" class="file-language eng" alt="eng"/><div class="file-size">(6736KB)</div></div><p>SHA-1:863d618829d8ee4680e2917e90e73da9870b9ced</p></li></ul></div><div id="export" class="services"><h3>Export metadata</h3><ul><li><a href="/citationExport/index/download/docId/40592/output/bibtex" title="Export BibTeX" class="export bibtex">BibTeX</a></li><li><a href="/citationExport/index/download/docId/40592/output/ris" title="Export RIS" class="export ris">RIS</a></li><li><a href="/export/index/index/docId/40592/export/xml/searchtype/id/stylesheet/example" title="Export XML" class="export xml">XML</a></li></ul></div><div id="additional-services" class="services"><h3>Additional Services</h3><div><a href="http://twitter.com/share?url=https://publishup.uni-potsdam.de/frontdoor/index/index/docId/40592"><img src="/layouts/pmatrix/img/twitter.png" name="Share in Twitter" title="Share in Twitter" alt="Share in Twitter"/></a> <a href="http://scholar.google.de/scholar?hl=de&amp;q=&quot;A framework for incremental view graph maintenance&quot;&amp;as_sauthors=Thomas+Beyhl&amp;as_ylo=2017&amp;as_yhi=2017"><img src="/layouts/pmatrix/img/google_scholar.jpg" title="Search Google Scholar" alt="Search Google Scholar"/></a> <a href="javascript:void(0)"><img src="/layouts/pmatrix/img/statistik.png" name="Statistics" title="Statistics" alt="Statistics" onclick="document.getElementById('oas').style.display='block'; document.getElementById('fade').style.display='block';&#10;$( &quot;#oas&quot; ).chart({ identifier: &quot;oai:kobv.de-opus4-ubp:40592&quot; })"/></a> </div></div></div><table class="result-data frontdoordata"><caption>Metadaten</caption><colgroup class="angaben"><col class="name"/></colgroup><tr><th class="name">Author:</th><td><a href="/solrsearch/index/search/searchtype/authorsearch/author/Thomas+Beyhl" title="Search for other publications by this author">Thomas Beyhl</a></td></tr><tr><th class="name">URN:</th><td><a href="https://nbn-resolving.org/urn:nbn:de:kobv:517-opus4-405929">urn:nbn:de:kobv:517-opus4-405929</a></td></tr><tr><th class="name">Advisor:</th><td>Holger Giese</td></tr><tr><th class="name">Document Type:</th><td>Doctoral Thesis</td></tr><tr><th class="name">Language:</th><td>English</td></tr><tr><th class="name">Year of Completion:</th><td>2017</td></tr><tr><th class="name">Publishing Institution:</th><td>Universität Potsdam</td></tr><tr><th class="name">Granting Institution:</th><td>Universität Potsdam</td></tr><tr><th class="name">Date of final exam:</th><td>2017/12/01</td></tr><tr><th class="name">Release Date:</th><td>2018/01/12</td></tr><tr><th class="name">Tag:</th><td><em class="data-marker">Discrimination Networks; Gator Netzwerk; Rete Netzwerk; inkrementelle Graphmustersuche; modellgetriebene Softwareentwicklung<br/>Gator networks; Rete networks; discrimination networks; incremental graph pattern matching; model-driven software engineering</em></td></tr><tr><th class="name">Pagenumber:</th><td>VII, 293</td></tr><tr><th class="name">Organizational units:</th><td><a href="/solrsearch/index/search/searchtype/collection/id/17145" title="Browse collection">An-Institute / Hasso-Plattner-Institut für Softwaresystemtechnik GmbH</a></td></tr><tr><th class="name">CCS Classification:</th><td><a href="/solrsearch/index/search/searchtype/collection/id/1931" title="Browse collection">H. Information Systems / H.3 INFORMATION STORAGE AND RETRIEVAL / H.3.3 Information Search and Retrieval / Search process</a></td></tr><tr><th class="name">Dewey Decimal Classification:</th><td><a href="/solrsearch/index/search/searchtype/collection/id/112" title="Browse collection">0 Informatik, Informationswissenschaft, allgemeine Werke / 00 Informatik, Wissen, Systeme / 000 Informatik, Informationswissenschaft, allgemeine Werke</a></td></tr><tr><th class="name">MSC Classification:</th><td><a href="/solrsearch/index/search/searchtype/collection/id/12543" title="Browse collection">68-XX COMPUTER SCIENCE (For papers involving machine computations and programs in a specific mathematical area, see Section {04 in that areag 68-00 General reference works (handbooks, dictionaries, bibliographies, etc.) / 68Wxx Algorithms (For numerical algorithms, see 65-XX; for combinatorics and graph theory, see 05C85, 68Rxx) / 68W01 General</a></td></tr><tr><th class="name">Licence (German):</th><td><img alt="License Logo" src="https://licensebuttons.net/l/by-nc-sa/4.0/80x15.png" title="https://creativecommons.org/licenses/by-nc-sa/4.0/deed.de"/><a href="/default/license/index/licId/24">Creative Commons - Namensnennung, Nicht kommerziell, Weitergabe zu gleichen Bedingungen 4.0 International</a></td></tr></table></div>

</div>                    </div>
                            </div>

            <div id="page-footer">
                <div class="wrapper">
                    <p id="logo-wrapper">
			<a href="http://www.kobv.de/opus4/" title="Opus4 Website"><img src="/layouts/pmatrix/img/logo/logo_small.gif" alt="OPUS4 Logo" title="" width="69" height="29" /></a>&nbsp;
			
			<a href="http://www.kobv.de" title="Hosted by KOBV"><img src="/layouts/pmatrix/img/logo/hosted-by-kobv.png" alt="KOBV Logo" title=""height="29"/></a>&nbsp;
			
			<a href="https://publishup.uni-potsdam.de/oai?verb=Identify" title="OAI BaseURL"><img src="/layouts/pmatrix/img/logo/oailogo_small.gif" alt="OAI Logo" title="" height="29"/></a>&nbsp;
			
			<a href="http://dini.de/ueber-dini/" title="DINI-Zertifikat"><img src="/layouts/pmatrix/img/logo/dini_zertifikat_2007_small.png" alt="DINI Zertifikat 2007" title="" height="35"/></a>&nbsp;
			
			<a href="http://open-access.net/" title="Open Access Netzwerk"><img src="/layouts/pmatrix/img/logo/openaccess_logo.png" alt="OA Netzwerk Logo" title="" height="35"/></a></p>
 
					<ul id="secondary-nav" class="nav">
                       <!-- <li class="first"><a href="/opus4-ubp/rss" title="RSS Feed"><img src="/layouts/pmatrix/img/feed.png" alt="RSS Feed" title="" height="14"/></a></li> -->            
                                                           		
			<li><a href="/opus4-ubp/home/index/help/content/edoc_start">Institutional Repository</a></li>
			
			<li><a href="/opus4-ubp/home/index/help/content/press_start">University Press</a></li>
			
			<li><a href="/opus4-ubp/home/index/help/content/bibliography_start">University Bibliography</a></li>
			
			<li><a href="http://info.ub.uni-potsdam.de">University Library</a></li>
			
			<li><a href="/opus4-ubp/home/index/help/content/policies">Policy</a></li>	
			
			<!-- <li><a href="http://info.ub.uni-potsdam.de/opusstat/">Statistics</a></li>-->
			
			<li><a href="/home/index/contact">Contact</a></li>
			
			<li><a href="/opus4-ubp/home/index/help/content/disclaimer">Disclaimer</a></li>
			
			<li class="last"><a href="http://www.uni-potsdam.de/kontakt/impressum.html">Imprint</a></li>
			
                        <!--<li class="last"><a href="/crawlers/sitelinks">Sitelinks</a></li>-->
                    </ul>
                    <p id="login-bar" class="nav"><a rel="nofollow" href="/auth/login/docId/40592/rmodule/frontdoor/rcontroller/index/raction/index">Login</a></p>
                    <!--<p id="copyright">&copy; <abbr xml:lang="de" title="Kooperativer Bibliotheksverbund Berlin-Brandenburg">KOBV</abbr> 2010-2011</p>-->
                </div>
            </div>
        </div>
		
   
    </body>
</html>
